Segger - Segment Map

Opening a density map

As an example, the density map of GroEL at 10.0Å resolution (EMD:1080), from the EMDB, will be used.

- It can be opened in Chimera by selecting File->Open....
- Instead of downloading it, you can also more simply choose "Fetch by ID ..." from the File menu, select "EMDB" and use the ID 1080. Either way, once open, the density map will appear in the main Chimera window:

EMDB: 1080 as it appears once opened

EMDB:1080 rotated around the x axis by ~90°
The Volume Viewer dialog will also appear if it wasn’t shown already:

![Volume Viewer dialog](image)

The Volume Viewer dialog can also be opened from Tools / Volume Data / Volume Viewer. It shows, amongst other information, a histogram of density values in the map. The gray bar can be dragged left or right to change the threshold, which is the density value used to generate the iso-surface shown in the main window. At higher thresholds, the inner and denser regions are seen, and at lower thresholds, the outer surface of the molecular complex is seen.

**Opening the Segment Map dialog**

The **Segment Map** dialog can be opened by selecting Tools / Volume Data / Segment Map. It looks like this:

![Segment Map](image)

**Segmenting the map**

To segment the map, first make sure the map to be segmented is selected in the field to the right of **Segment map** in the Segment Map dialog. This field is a drop-down menu, showing all the density maps currently open.

- **Note** that if you open the Segment Map dialog after opening one or more density maps, an open map will already be selected by default. To select another map, click on the field, and then select it from the drop-down menu that appears.
When segmenting a map, a density threshold is applied, and only density values above this threshold will be included in the segmentation. The threshold chosen for the density map in the Volume Viewer interface is used; this is the same threshold (or contour level) used to draw the surface you see in the main Chimera window.

Once you’ve adjusted the threshold, to for example 1.12 as in this example, click the Segment button. After a few seconds, you will see the segmentation results in the main Chimera window, replacing the map previously shown there:

In the above segmentation, groups of two regions correspond to each protein. To see how to get a segmentation in which each region matches a single protein, read on...

**Results of segmentation**

Segmentation produces a number of regions, with each region containing only adjacent (26-connected) voxels. Each region is shown as a smooth surface surrounding the voxels it contains.

All the segmentation information is kept in a separate model in Chimera, which for the example above will have the name emd_1080.seg. You will see this model appear in the Model Panel dialog after pressing the "Segment" button.

After segmenting, also notice three changes in the Segment Map dialog:
- The name of the segmentation output file will appear in the field to the right of Current segmentation. In this example, it’s emd_1080.seg.
- To the right of that, it will say 28 regions. This is the number of regions produced.
• At the bottom of the Segment Map dialog, just above the Segment button, it will also say *428 watershed regions, smoothed 3 voxels to get 28 regions*. Look at this line for other messages as you segment.

**Segmentation method**

Segger uses the [watershed method](#). The regions produced by the watershed method are often small and numerous - an effect often referred to as over-segmentation. To reduce this effect, and produce larger and more meaningful regions, Segger uses [scale-space filtering](#) to group the many, small, resulting regions, into larger, more meaningful regions.

The watershed regions produced for the GroEL map are shown below in first image on the left. To produce fewer and larger regions, the density map is smoothed and the regions are grouped based on the smoothed map. This is repeated for a number of steps. The step size specifies how much smoothing takes place. By default, 3 steps of size 1 are used, leading to a segmentation as shown in the image in the middle.

There are several ways to direct this smoothing and grouping process:

- Continuing with the example so far, simply press the **Group** button. When no regions are selected, this button simply does more smoothing and grouping of regions. It does more smoothing steps automatically, until the number of regions changes. In this case, it takes 3 more steps, since only after this many more steps does the number of regions changes from 28 to 14.
- Click the **Options** button in the Segment Map interface, enter 6 for the number of *Smoothing steps* (leaving 1 as step size), and then press the **Segment** button. Now the map is segmented again (which wasn't really necessary, but it does a "clean" start in case you've been changing regions yourself already). Then 6 (this is the number you entered) smoothing steps are performed, and because more smoothing is performed, fewer regions are obtained - 14 regions. In this case, this is the same number of regions as
proteins. The number 6 was arrived at after some experimentation, so do experiment with different numbers for your map.

- If we already knew there were 14 proteins in this density map, we can also enter a larger number of smoothing steps (e.g. 100), and 14 in the field to the right of *Stop grouping if number of regions* <=. With these options, smoothing steps (up to 100 of them) are taken, until the number of regions drops to 14. Of course it doesn’t need to do all 100, it only does 6 as the other examples have shown.

**Segmentation options**

To change parameters for the segmentation process, press the **Options** button at the bottom of the Segment Map window to display the Options pane. The Segment Map dialog with the **Options** shown looks as follows:

![Segmentation Options](image)

**Number of smoothing steps and step size**

- You can specify a different number of smoothing steps and step size. If it looks like the regions obtained should be larger and there should be fewer of them, increase the number of smoothing steps.
  - Instead of changing this parameter, you can always:
    - Backtrack after segmenting – press the ‘Ungroup’ button at the bottom of the dialog with no regions selected. This is the same as selecting one less number of steps and pressing segment again.
    - Group further by pressing the ‘Group’ button at the bottom of the dialog with no regions selected. This is the same as entering one more than the number in the number of steps and pressing segment again.
The step size parameter will also change the results, but not as significantly:

- When smaller step sizes are used, less smoothing is performed at each step, and so the number of and the shape of each region will change more gradually; thus to get fewer regions, more steps will be required.
- With larger step sizes, changes will be more drastic, but fewer steps will be required to get to a particular number of regions. Experiment with different numbers on your map... When the map contains a lot of noise, larger steps are recommended, since smoothing tends to reduce the bad effects of noise.
- For ungrouping and regrouping purposes (discussed further below), use smaller step sizes and more steps, since this will give you a more gradual change in number of regions at each ungrouping step.

Region size filter

- Regions can be filtered by size. This can be used to remove any regions that are very small and would likely be due to noise. Regions that consist of fewer voxels than the number entered in the field to the right of keep only regions having at least are ignored. By default, this number is 1, meaning that every segmented region will be displayed (a region can only exist if it has at least one voxel in it). Note that this filter is applied to the initial segmentation process only, and not after smoothing has been performed.

Stop grouping if number of regions <= ______

- In some cases, you might know how many proteins you are looking for in a density map. For example, GroEL contains 14 proteins, so we knew ahead of time were were aiming to get 14 regions. This number can be entered in the field to the right of Stop grouping if number of regions <=. The process stops when this number of regions is reached. So even if a large number of steps was entered in smoothing steps, only 6 steps would be taken, since after this number of steps, the number of regions becomes 14.

Display at most ______ regions

- The number of regions in some density maps can be quite large (tens of thousands). With this many regions, performance becomes very slow. Hence, the number entered in Display at most... regions' limits how many regions are shown. By default this number is 2000. The regions are still there in the segmentation, but they are just not shown.
  - If you segment a map and don't see regions where there should be regions, you can try increasing this number and then segmenting again.
  - Even when not all the regions are shown at first, they are still used when smoothing and grouping. So if you get more regions than you can view, you can try using more smoothing steps, which will produce fewer regions.
Surface granularity
  o You can reduce the surface complexity of each region by increasing this number. This leads to faster display times, but also less smooth surfaces.

Using Segger with your own map

Now that you have a better idea of how Segger works, and what the parameters do, go ahead and try Segger with your own map. Load the map in Chimera, select it in the field to the right of Segment map, choose a threshold in the Volume Viewer dialog, and then press Segment. Adjust the segmenting parameters and try again, as necessary.

Selecting and working with regions

In the main Chimera window, where the segmented regions are shown, a region can be selected using the usual Chimera selection mechanism. For example, while holding the Control/Ctrl key, clicking on a region selects it (you will see a greenish border around it), or unselects it if it is already selected.

Multiple regions can also be selected; clicking on a region while holding Shift+Control adds it to the current selection if it isn’t already in the selection, or removes it from the selection if it is in the selection already.

Other important operations are grouping and ungrouping regions.
  • To group two or more regions, select them and then press the Group button at the bottom of the Segment Map dialog. The regions will now be combined, and shown using a single surface.
  • To ungroup one or more regions, select it/them and then press the Ungroup button at the bottom of the Segment Map dialog. You can ungroup regions that you previously grouped, or which were grouped by smoothing and grouping! In the latter case, the effect is to ‘undo’ smoothing in select parts of the map, i.e. the parts that are covered by one or more regions...

Editing the segmentation

Grouping and ungrouping can be used to modify the resulting segmentation, to adjust for example a region that looks wrong. This process is illustrated below - first the orange region in the image on the left is ungrouped, producing smaller regions, which are then regrouped with nearby regions.

If you try to ungroup a region you obtained by smoothing and grouping (simply having pressed the Segment button with multiple smoothing steps), and it gets
ungrouped into too many small regions, then you can try redoing the process, but using more steps, and steps that are smaller in size. This way, the grouping will be more gradual, and the intermediate regions sizes and numbers will drop more gradually.

Shortcuts

Selected regions can be hidden, deleted, made transparent, etc., by selecting the one of the entries in the **Regions** menu which appears at the top of the Segment Map dialog. For convenience, some of these functions are accessible by pressing “Shortcuts” at the bottom of the Segment Map dialog:

- **Select regions:**
  - Pressing one of these buttons will select regions in the current segmentation (the one selected at the top of the Segment Map dialog).
    - All – all regions
    - Overlapping selected atoms – regions that overlap selected atoms
    - Invert Selection – all regions currently not selected

- **Selected regions:**
  - Pressing one of these buttons will perform an operation on the selected regions:
    - Hide – hide selected regions
    - Show – show selected regions
    - Delete – regions will be deleted from the segmentation
    - Transparent – selected regions become transparent
    - Opaque – selected regions become opaque
- **Show regions:**
  - Pressing one of these buttons will affect which regions are being shown:
    - All – all regions, up to the number entered in Options for Display at most ___ regions. Note that regions are shown in order of size from largest to smallest, so the ___ largest regions are shown – if regions are interactively re-grouped, pressing this button is useful to reorder and show the new ___ largest.
    - Only selected – only the selected regions.
    - Adjacent – regions that are adjacent to any selected regions.
    - Grouped – only regions that are made up of 2 or more subregions are shown.

- **Other tools:**
  - Some other tools that make use of segmented regions (see corresponding tutorials [here](#)):
    - Fit – rigidly dock models based on segmented regions
      - Note this is the same as the dialog that shows up when selecting Tools -> Volume Data -> Fit to Segments.
    - Extract – extract densities inside segmented regions
    - rSeg – group regions based on radial distance
    - SegMod – add loops to models based on segmented regions
    - ProMod – combine multiple (flexible) fitting results into probabilistic models

**Saving segmentation results**

You can save and load a previously saved segmentation through the File menu at the top of the Segment Map dialog. Region colors are also saved along with the segmentation.