Segger – Extract

Last updated: Oct. 23, 2015 (Segger v1.9.2, Chimera Version 1.11.0)

Overview of Extract Dialog

The Extract dialog allows you to mask out parts of a density map based on segmented regions. This can create smaller maps of individual components. There are various options as shown in the dialog, which can be launched from the Segment Map dialog -> Shortcuts -> Other tools -> Extract button.

The options are as follows:
Extract densities from map
  o The map selected here is where the densities are extracted from.
    • When opening this dialog, if there is a map/segmentation selected in
      the Segment Map dialog, the selection will be that same map.
  o The map/segmentation selected in Segment Map dialog is what the Extract
    dialog will use as the mask.
  o The selected regions are used as the mask.

Dimensions of new map
  o Same as map from which densities are extracted
    o The new map will have the same dimensions
  o Cube around region, with border of $[b]$ voxels
    o A cube will be fitted around the selected regions, the new map will
      have dimensions of the smallest cube (all sides same length), plus a
      border of $b$ voxels.
  o Box around region, with border of $[b]$ voxels
    o The extracted map will have smallest lengths on each side possible
      that still fit the selected regions, plus a border of $b$ voxels added to
      each side.
    o For both cube and box options, the axes of the new map are the same
      as the axes of the map from which densities are being extracted, but
      the origin will be different, so that the extracted densities align exactly
      within the map from which they are extracted.

Which densities to extract
  o Only densities inside the selected region(s)
    o The selected regions will be used as a hard mask applied to the map
      from which densities are extracted (selected at the top of the dialog).
  o All densities inside the bounds of the new map
    o The selected regions are only used to determine the dimensions of the
      cube or box (plus border) that the extracted map will have, but all
      densities inside the cube or box will be extracted.
    o If the “Same as map from which densities are extracted” is selected for
      Dimensions of new map, then having this option selected means you
      get back exactly the same map, unless the Smooth mask option below
      is selected... In that case, the selected regions are combined into a
      hard mask, which is smoothed before being applied.

What maps to create
  o A map spanning all selected regions
    • The selected regions are all combined into one mask, so only one map
      will result
  o A map for each selected region
    o A map for each selected region will result
Add fall-off densities outside region boundary with width \([w]\) Angstroms
- The mask created from the selected region(s) has a steep boundary, because all voxels inside have a value of 1, and all voxels outside have a value of 0.
- When selected, this option makes the mask so that all voxels inside are still 1, but they drop towards 0 gradually, over the with \(w\) (in Å) specified.

Low-pass result with Gaussian filter width: \([w]\)
- The resulting, extracted map is low-passed with a Gaussian of the specified width (in Å).

Smooth mask - gaussian width: \([w]\)
- To use this option, make sure to also select “All densities inside the bounds of the new map” for the **Which densities to extract** option.
- The mask created from the selected region(s) is low-passed filtered using a Gaussian of width \(w\) (in Å).
- The difference from the fall-off option is that with this option, the mask no longer has values of 1 inside the regions, so the densities inside the regions will be changed. However this option should be used when the extracted masks are to be used for comparison of independent maps via FSC plots, for example.

Resample result on grid of another map:
- The extracted densities are interpolated onto the grid of the map selected in this field. This is useful in various scenarios, e.g. for density averaging, or FSC calculation.

Save map(s) with name:
- The newly extracted maps will be saved in the same folder where the selected map at the top of the dialog is stored.
- Because there can be multiple maps if the “A map for each selected region” is selected in **Which densities to extract**, the text should also contain %s or %d, which will be replaced with the region id, or an incrementing number, respectively.

The Extract button at the bottom of the dialog performs the extraction. Look for new model(s) created in the Model Panel and the main Chimera window.
Example – Masking for Gold-standard FSC calculation

In this example, we will extract densities from two independent maps, and estimate the resolution for the entire maps as well as for a sub-component using FSC plots.

For this tutorial, the files can be obtained from this link:
https://www.dropbox.com/s/33lgeqo28to6syp/segger_tutorial_extract.zip

The files at the link include two maps (P22_virion_A.mrc and P22_virion_B.mrc), as well as two segmentation files (P22_virion_A.seg and P22_virion_B.seg).

1. Opening the maps and segmentations
   - Open the maps by going to File -> Open, navigate to downloaded files, and open the first map, P22_virion_A.mrc
     - In the Volume Viewer dialog, click on the ‘step’ box (showing 8), and select 1.
     - Turning the map ~90° about the x-axis:

   - Open the Segment Map dialog from Tools -> Volume Data.
   - In the Segment Map dialog, with the map selected, click on the field to the right of ‘Current Segmentation’.
   - A popup will show any opened segmentations, and also segmentations in the same path (and same name) as the map selected in the ‘Segment map’ field.
Select P22_virion_A.seg

After a couple of seconds, you will see the segmentation.

- You’ll notice that after the segmentation opens, the field next to Segment map goes blank. That’s because Chimera can’t find the map associated with the segmentation (the segmentation saves the path to the map).
- To re-associate the map and segmentation, select the map in the ‘Segment map’ field, and then select File -> Associate selected (in the Segment Dialog).
- To save the association, save the segmentation again by selecting File -> Save segmentation.

Do all steps above for P22_virion_B.mrc and P22_virion_B.seg

2. Selecting and Extracting the Portal

Select P22_virion_A.seg in the Segment Dialog next to Current Segmentation. Hide all other models except P22_virion_A.seg in the Model Panel, so you can only see the segmentation.

In the main UCSF Chimera window, click-select regions one at a time and hide them, leaving only the portal which has a green color.

- The fastest way to do this is to open the Shortcuts on the Segment Dialog (press the Shortcuts button on the bottom row of the dialog). Then select the regions one at a time and press the Hide button to the right of Selected regions. Once you see the portal in green, select it and press Show regions: Only Selected.

Make sure only the (green) portal region is selected (ctrl+left click on it in the main window).

Open the Extract Dialog by pressing the Extract button in the Segment Dialog shortcuts.

- To quickly see what the actual densities look like, press the Extract button at the bottom.
  - This will create a new map with only the densities inside the portal region.
  - Make only this model visible in the Model Panel to have a look.
- Vary the threshold of this new map in the Volume Viewer dialog.
- The histogram shows 0 voxels have densities below the threshold used to segment the map.
  - To smooth the histogram and the edges of the map, experiment with the “Add fall-off densities...” and “Low-pass result...” in the Extract dialog. (Press Extract again after selecting these options).
- Note also that that this map has much smaller dimensions than the original map.

All the segmented regions. Note that the coat is transparent, showing the first layer of packaged DNA.

The region for the portal, in green.
3. Extracting the Portal for FSC Calculation

- For FSC calculation, we should extract the maps to have the same size in all dimensions:
  - From Map A:
    - Select P22_virion_A.seg in Segment Map dialog
    - Select only the portal region (green) in the main window
    - Press the Extract button in Shortcuts to open the Extract Dialog
    - Use the following options:
      - Press Extract at the bottom of the dialog.
      - Note the extracted map will be automatically saved in the same folder as the map, since we selected the last option (Save map(s)...) and gave it a name for the file.

- From Map B:
  - Here we want to do the same thing for Map B, but when extracting the portal, we want to make sure the extracted map has the same grid (dimensions and position) as the extracted portal from Map A.
  - Select P22_virion_B.seg in Segment Map dialog
  - Select only the portal region (green) in the main window
- Press the **Extract** button in **Shortcuts** to open the **Extract Dialog**
- Use the following options:

  - **Extract Densities** (Segger v1.9.2)
  - **Extract densities from map:** P22_virion_B.mrc
  - **Dimensions of new map:**
    - [ ] Same as map from which densities are extracted: 512 512 512 voxels
    - [ ] Cube around region, with border of 8 voxels
    - [ ] Box around region, with border of 8 voxels
  - **Which densities to extract:**
    - [ ] Only densities inside the selected region(s)
    - [X] All densities inside the bounds of the new map
  - **What maps to create:**
    - [ ] A map spanning all selected regions
    - [ ] A map for each selected region
  - [ ] Add fall-off densities outside region boundary with width ~ 22 Angstroms
  - [ ] Low-pass result with gaussian filter width: 2.0
  - [X] Smooth mask - gaussian width: 10 Angstroms
  - [X] Resample result on grid of another map: P22_virion_A_portal.mrc
  - [X] Save map(s) with name: P22_virion_B_portal.mrc
    (\%s in name -> region id, \%d -> incrementing numbers starting with 1)

- **Note the important difference:**
  - [X] Resample result on grid of another map: P22_virion_A_portal.mrc
    - This will make sure that the two extracted maps are aligned and on the same grid, necessary for FSC calculation.
  - Press **Extract** at the bottom of the dialog.
  - Note the extracted map will be automatically saved in the same folder as the map, since we selected the last option (Save map(s)...) and gave it a name for the file.

Note that we could avoid the **Resampling** step when extracting map B if both portals were extracted with the following option:

- **Dimensions of new map:**
  - [ ] Same as map from which densities are extracted

- **But:**
  - The FSC plots will be nearly identical.
  - The benefit of doing it as we did is that the portal maps are much smaller in dimensions, and hence take up much less disk space, avoiding storing maps that have mostly \(\sim 0\) density values anyway.
4. Calculating and plotting FSC with EMDB

- We can use the [EMDB FSC validation server](http://www.ebi.ac.uk/pdbe/emdb/validation/fsc/) to calculate and plot the FSC between the two maps.
  - Navigate to the link in a browser:
    - http://www.ebi.ac.uk/pdbe/emdb/validation/fsc/
  - Select first the entire maps, P22_virion_A.mrc and P22_virion_B.mrc
    - The voxels size is 2.55Å
    - All other options can be left at default values.
  - Then select only the portal maps, P22_virion_A_portal.mrc and P22_virion_B_portal.mrc
  - The two plots are shown below. Note how the resolutions can vary throughout each component vs. the entire map.
5. Calculating and plotting FSC with EMAN and pyplot

- The FSC can also be calculated with EMAN. In a terminal, navigate to the segger_tutorial_extract path, then enter the commands:
  - `e2proc3d.py --apix 2.55 --calcfsc P22_virion_A.mrc P22_virion_B.mrc P22_virion.txt`
  - `e2proc3d.py --apix 2.55 --calcfsc P22_virion_A_portal.mrc P22_virion_B_portal.mrc P22_virion_portal.txt`

- This will create two files:
  - `P22_virion.txt`
  - `P22_virion_portal.txt`

- Use the plot.py file to plot the FSCs using python:
  - `python plot.py`